robotnix-fp3/flake.nix

49 lines
1.9 KiB
Nix

{
description = "A basic example robotnix configuration";
inputs.robotnix.url = "github:danielfullmer/robotnix";
outputs = { self, robotnix }: {
# "dailydriver" is an arbitrary user-chosen name for this particular
# configuration. Change it to something meaningful for you, perhaps just
# the device name if you only have one of this kind of device.
robotnixConfigurations."fp3" = robotnix.lib.robotnixSystem
({ config, pkgs, ... }: {
# These two are required options
device = "FP3";
flavor = "lineageos";
# buildDateTime is set by default by the flavor, and is updated when those flavors have new releases.
# If you make new changes to your build that you want to be pushed by the OTA updater, you should set this yourself.
# buildDateTime = 1584398664; # Use `date "+%s"` to get the current time
# signing.enable = true;
# signing.keyStorePath = "/var/secrets/android-keys"; # A _string_ of the path for the key store.
# Build with ccache
# ccache.enable = true;
androidVersion = 11;
apps.fdroid.enable = true;
apps.chromium.enable = false;
microg.enable = true;
webview.chromium.enable = false;
webview.prebuilt.enable = true;
## Custom hosts file
#hosts = pkgs.fetchurl { # 2019-08-14
# url = "https://raw.githubusercontent.com/StevenBlack/hosts/449a0d7f613e6518ede4f3333e94f8071d3f1cd3/hosts";
# sha256 = "1mcn77l2m45qms7ynww2hzx0d6mja03bzj4di0s9j7spycp4540i";
#};
ccache.enable = true;
});
# This provides a convenient output which allows you to build the image by
# simply running "nix build" on this flake.
# Build other outputs with (for example): "nix build .#robotnixConfigurations.dailydriver.ota"
defaultPackage.x86_64-linux = self.robotnixConfigurations."fp3".img;
};
}