dotfiles/nixos/home-manager/default.nix
Cyryl Płotnicki 635f5902aa
Some checks are pending
use nix / build (push) Waiting to run
cleanup, make checks pass
2024-04-27 11:33:38 +01:00

37 lines
598 B
Nix

{
config,
pkgs,
inputs,
lib,
...
}: let
username = "cyryl";
in {
home = {
inherit username;
sessionVariables = {
LC_ALL = "en_GB.UTF-8";
LANG = "en_GB.UTF-8";
PASSWORD_STORE_ENABLE_EXTENSIONS = "true";
};
packages = with pkgs; [];
homeDirectory = lib.mkDefault "/home/${username}";
stateVersion = "23.11";
};
news.display = "show";
programs.home-manager.enable = true;
imports = [
./cli.nix
./links.nix
./scripts.nix
./programs.nix
./programs/newsboat.nix
./programs/ssh.nix
./programs/tmux.nix
];
}