dotfiles/nixos/boxes/skinnyv/hardware-configuration.nix
Cyryl Płotnicki 02b5b07993
Some checks failed
use nix / build (push) Failing after 3m27s
cleanup, statix fixes
2024-04-21 19:16:41 +01:00

43 lines
881 B
Nix

{
config,
lib,
pkgs,
modulesPath,
...
}: {
imports = [(modulesPath + "/installer/scan/not-detected.nix")];
boot = {
initrd.availableKernelModules = ["xhci_pci" "ahci" "usb_storage" "sd_mod"];
kernelModules = ["kvm-intel"];
initrd.luks.devices."crypt".device = "/dev/disk/by-uuid/0c192a18-178f-4598-a1ed-5295ef2abdc4";
};
fileSystems."/" = {
device = "/dev/disk/by-uuid/9dba116f-c9fe-403a-a8e2-f9fdab23f1f1";
fsType = "btrfs";
options = ["compress=zstd"];
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/0A6A-AAFC";
fsType = "vfat";
};
swapDevices = [
{
device = "/swapfile";
size = 16 * 1024;
priority = 1;
}
];
zramSwap = {
enable = true;
algorithm = "zstd";
memoryPercent = 25;
priority = 10;
};
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
}