dotfiles/nixos/boxes/skinnyv/default.nix
Cyryl Płotnicki 635f5902aa
Some checks are pending
use nix / build (push) Waiting to run
cleanup, make checks pass
2024-04-27 11:33:38 +01:00

35 lines
638 B
Nix

{
config,
pkgs,
...
}: {
networking.hostName = "skinnyv";
imports = [
./hardware-configuration.nix
../../boot.nix
../../backups.nix
../../distributed-builds.nix
../../gfx-intel.nix
../../git
../../gui
../../i3
../../mercurial
../../vim
../../zsh
];
boot = {
kernelPackages = pkgs.linuxPackages_latest;
loader = {
systemd-boot.enable = true;
efi.canTouchEfiVariables = true;
};
time.timeZone = "Europe/London";
};
services.thermald.enable = true;
home-manager.users.cyryl = {...}: {
imports = [../../home-manager/programs/kitty.nix];
};
}