dotfiles/nixos/boxes/nginx.nix

17 lines
327 B
Nix

{
config,
pkgs,
...
}: {
networking.firewall.allowedTCPPorts = [80 443];
services.nginx = {
enable = true;
statusPage = true;
clientMaxBodySize = "512M";
recommendedTlsSettings = true;
recommendedOptimisation = true;
recommendedGzipSettings = true;
recommendedProxySettings = true;
};
}