dotfiles/nixos/boxes/cupsnet/default.nix
Cyryl Płotnicki e86486bc36
All checks were successful
use nix / build (push) Successful in 22m6s
add novena image def, update
2024-05-07 17:41:56 +01:00

42 lines
661 B
Nix

{
config,
pkgs,
inputs,
lib,
...
}: {
imports = [
"${inputs.nixpkgs-stable}/nixos/modules/profiles/qemu-guest.nix"
../cli.nix
../send-logs.nix
./backups.nix
./boot.nix
./cryptpad.nix
./disks.nix
./forgejo.nix
./foundryvtt.nix
./gitea-runner.nix
./mastodon.nix
./rss.nix
./ssh.nix
./videos.nix
];
networking.hostName = "cupsnet";
boot.binfmt.emulatedSystems = ["armv7l-linux"];
zramSwap = {
enable = true;
algorithm = "zstd";
memoryPercent = 50;
};
swapDevices = [
{
device = "/swapfile";
size = 16384;
}
];
time.timeZone = "Europe/London";
}