blog/flake.nix
2025-01-11 21:58:52 +00:00

41 lines
872 B
Nix

{
description = "Adventurous computing, a blog by Cyryl Płotnicki";
inputs = {
utils.url = "github:numtide/flake-utils";
flake-compat = {
url = "github:edolstra/flake-compat";
flake = false;
};
nixpkgs-marmite = {
type = "github";
owner = "NixOS";
repo = "nixpkgs";
ref = "master";
};
};
outputs = {
self,
nixpkgs,
utils,
nixpkgs-marmite,
flake-compat,
}:
utils.lib.eachDefaultSystem (system: let
pkgs = nixpkgs.legacyPackages."${system}";
marmite-pkgs = nixpkgs-marmite.legacyPackages."${system}";
in {
devShell = pkgs.mkShell {
buildInputs = with pkgs;
with marmite-pkgs;
with pkgs.python3Packages; [
cacert
git
htmltest
marmite
rsync
statix
];
};
});
}